How to update the Novell GroupWise Client

Article ID: KB04164

Type: Support Content

Last Modified: 12-14-2011

 

Product(s) Affected:

  • BlackBerry Enterprise Server for Novell GroupWise
CollapseEnvironment
  • BlackBerry® Enterprise Server versions 4.0 to 4.1 for Novell® GroupWise®
CollapseOverview

Background

All communication between the BlackBerry® Enterprise Server and the Novell® GroupWise® system is handled by the Novell GroupWise Object Application Programming Interface (API), which is included with the Novell GroupWise Client. In BlackBerry Enterprise Server software version 4.1 SP2 to SP7, a Simple Object Access Protocol (SOAP) API mode is also available which handles some processing using event notification, however, the majority of data retrieval is still performed using the Novell GroupWise Object API. BlackBerry Technical Support Services has found that a number of issues can be resolved by applying the latest Service Pack, Hotfix, or Field Test File (FTF) update to the Novell GroupWise Client version 6.5, 7.0 or 8.0.

IMPORTANT: While the improvements contained in the updates are cumulative and are normally beneficial, they are not all fully certified by Research In Motion. Previous updates to the Novell GroupWise Object API only required an update to the gwcma1.dll file. With the latest versions of the Novell GroupWise Object API, a full installation of the Novell GroupWise Client is required.

Choosing the appropriate GroupWise Client:

It is recommended that the Novell GroupWise Client installed on the BlackBerry Enterprise Server be at the same or earlier version than the Novell GroupWise Post Office Agent version. To maintain the best compatibility, the Novell GroupWise Client should remain on the same code stream, whether 6.5, 7.0 or 8.0. For Novell documentation on the supportability of newer Novell GroupWise Clients against older Novell GroupWise Post Office versions, go to www.novell.com/support and search for Novell Technical Information Document (TID) 7000468.

At the time of writing, the latest released versions of the Novell GroupWise Client are:

  • Novell GroupWise 8 SP2 Hot Patch 2 Windows Client US and MULTI (TID 5086723)
  • Novell GroupWise 7 SP3 HP5 Client Api Fix for Blackberry Enterprise Server (BES) - US & Multi (TID 5062620)

Note: The above Novell GroupWise Client versions have not yet completed full testing within a BlackBerry Enterprise Server version 4.1.6 environment. They are supported "best effort", but have not yet been fully certified to become the recommended client to use. A minimum BlackBerry Enterprise Server version of 4.1.6 MR4 should be applied before implementing these clients. For more information, see article KB17715.

To view the current BlackBerry Compatibility Matrix, go to http://na.blackberry.com/eng/support/software/server_compatibility.jsp#tab_tab_compatibility and click on 'BlackBerry Enterprise Server for Novell GroupWise Compatibility Matrix' to verify the latest supported GroupWise Client and GroupWise Server versions.

For more information on any of these Novell GroupWise Client versions, go to www.novell.com/support and search for the listed TIDs.

For a list of GroupWise Client versions and the GroupWise Object API gwcma1.dll versions, go to http://wiki.novell.com/index.php/GroupWise_Release_History

To update the Novell GroupWise Object API, complete the following steps:

  1. From the Novell support web site, download the latest service pack or FTF for the Novell GroupWise Client versions 6.5, 7.0, or 8.0. The service pack or FTF will contain the current version of the Novell GroupWise Object API.
  2. Open the Windows® Services administrative tool.
  3. Stop the appropriate services:
    • For BlackBerry Enterprise Server software version 4.1, stop the BlackBerry Controller and the BlackBerry GroupWise service
    • For BlackBerry Enterprise Server software version 4.0, stop the BlackBerry Controller service

    Important: Restarting certain BlackBerry Enterprise Server services will delay email message delivery to BlackBerry smartphones. For more information, see article KB04789.

  4. On the computer hosting the BlackBerry Enterprise Server, close the BlackBerry Manager and the Novell GroupWise Client.
  5. Remove the Novell GroupWise Client version currently installed on the computer hosting the BlackBerry Enterprise Server.
  6. Install the updated Novell GroupWise Client version 6.5, 7.0, or 8.0 by following the installation instructions outlined by Novell.

    Note: You must select the US-English language when you install the Novell GroupWise Client.

  7. Start the services that were stopped in Step 3.
  8. To make sure the Novell GroupWise Client is operating correctly, open the Novell GroupWise Client and log in.
  9. Open the Novell GroupWise address book and verify that no errors have been reported.
CollapseAdditional Information

Certain versions of BlackBerry Enterprise Server for Novell GroupWise have a minimum GroupWise Client version as a prerequisite:

  • BlackBerry Enterprise Server version 4.0 SP6, and BlackBerry Enterprise Server software version 4.1 SP2 Hotfix 1 and require the Novell GroupWise 6.5 Post SP6 Client Rev 4 or later as a prerequisite. These versions are required to support certain FID Checking algorithms which occur upon login
  • BlackBerry Enterprise Server version 4.1 SP2 to SP6 running in SOAP mode requires a minimum of the Novell GroupWise 7.0.1 IR1 Client or later
  • BlackBerry Enterprise Server version 4.0 SP7 and BlackBerry Enterprise Server software version 4.1 SP4 to SP6 support the Novell GroupWise 7.0 Client
  • BlackBerry Enterprise Server version 4.1 SP4 MR1 to SP6 support the Novell GroupWise 7.0.3 Client (SDR172630)

Novell GroupWise Client versions 6.5 and 7.0 dated May 24, 2007 and later will only be able to connect to Novell GroupWise Post Offices which have been updated to specific versions. For more information go to www.novell.com/support and search for TID 3382383.

If all GroupWise Post Office Agents are not upgraded to at least Novell GroupWise 7.0.2 HP1a, remain on the FTF: Novell GroupWise 6.5 Post SP6 Client Rev 4 Multi. For more information, go to www.novell.com/support and search for TID 2974707.

Obsolete GroupWise Client Versions:

  • Novell GroupWise 8 SP1 Hot Patch 1 Windows Client US and MULTI (TID 5066441)
  • Novell GroupWise 8.0 SP1 Windows Client US and MULTI (TID 5056781)
  • Novell GroupWise 8.0 Hot Patch 2 Windows Client US and MULTI (TID 5050002)
  • FTF: GroupWise 7.0.2 Hot Patch 2 Windows client Rev 1 702HP1a (TID 5004823)
  • Novell GroupWise 7 SP3 Hot Patch 1 Windows Client US and MULTI (TID 5028301)
  • Novell GroupWise 7 SP3 Hot Patch 2 Windows Client US and MULTI (TID 5041501)
  • Novell GroupWise 7 SP3 Hot Patch 3 Windows Client US and MULTI (TID 5049740)
  • Novell GroupWise 7 SP3 Hot Patch 3 FTF (TID 5052080)
  • Novell GroupWise 7 SP3 Hot Patch 4 Windows Client US and MULTI (TID 5058260)
  • FTF: Novell GroupWise 6.5.6 Update 2 Windows client (TID 5004629)
  • Novell GroupWise 6.5.6 Update 3 Windows client 656up3 (TID 5009060)
  • FTF: Novell GroupWise 6.5 Post SP6 Client Rev 4 Multi (TID 2974707)

For more information on obsolete versions, go to www.novell.com/support and search for the listed TIDs.

Disclaimer

By downloading, accessing or otherwise using the Knowledge Base documents you agree:

   (a) that the terms of use for the documents found at www.blackberry.com/legal/knowledgebase apply to your use or reference to these documents; and

   (b) not to copy, distribute, disclose or reproduce, in full or in part any of the documents without the express written consent of RIM.


Visit the BlackBerry Technical Solution Center at www.blackberry.com/btsc.