Support for Java Runtime Environment 7 on BlackBerry Enterprise Server and BlackBerry Enterprise Service 10

Article ID: KB33977

Type: Support Content

Last Modified: 07-31-2014

 

Product(s) Affected:

  • BlackBerry Enterprise Service 10
  • BlackBerry Enterprise Server
  • BlackBerry Mobile Fusion Studio
  • BlackBerry Device Service
  • Universal Device Service
CollapseEnvironment
  • BlackBerry Enterprise Server 5.0 to 5.0 SP4 MR7
  • BlackBerry Enterprise Server Express 5.0 to 5.0 SP4
  • BlackBerry Enterprise Service 10
  • Java Runtime Environment
  • DT 6303640
CollapseOverview

BlackBerry Enterprise Server 5.0:

Prior to BlackBerry Enterprise Server 5.0 SP4 MR7, BlackBerry Enterprise Server components are unable to leverage the version of JBoss included with Java Runtime Environment 7.

Support for Java Runtime Environment (JRE) 7 is available with the release of BlackBerry Enterprise Server 5.0 SP4 MR7. The version of JBoss used within the BlackBerry Administration Service was upgraded in MR7 to support JRE 7.

BlackBerry Enterprise Server Express 5.0:

BlackBerry Enterprise Server Express 5.0 components are unable to leverage the version of JBoss included with Java Runtime Environment 7.

BlackBerry Enterprise Service 10:

BlackBerry Enterprise Service 10 version 10.0 components are unable to leverage the version of JBoss included with Java Runtime Environment 7.

Starting in BlackBerry Enterprise Service 10 version 10.1, Java Runtime Environment 7 is supported and the components require JRE 7.

CollapseAdditional Information

An upgrade to a version of BlackBerry Enterprise Server or BlackBerry Enterprise Service 10 that supports JRE 7 will not automatically uninstall existing versions of JRE 6.

Older versions of JRE 6 can be manually uninstalled if no other applications are using those versions of Java, but the removal of old Java installations is optional.

JRE 7 and JRE 6 can co-exist as long as each component that leverages Java is configured to use the correct version of Java.

See the following articles for how to configure components to use a particular supported version of Java:

BlackBerry Enterprise Server 5.0: KB17872.

BlackBerry Enterprise Service 10 version 10.0: KB34527.

BlackBerry Enterprise Service 10 version 10.1 and later: KB34385.

The Java Development Kit (JDK) was used by the BlackBerry Monitoring Service in BlackBerry Enterprise Server 5. The JDK is not required for BlackBerry Enterprise Server 5.0 SP4 or BlackBerry Enterprise Service 10.

Disclaimer

By downloading, accessing or otherwise using the Knowledge Base documents you agree:

   (a) that the terms of use for the documents found at www.blackberry.com/legal/knowledgebase apply to your use or reference to these documents; and

   (b) not to copy, distribute, disclose or reproduce, in full or in part any of the documents without the express written consent of RIM.


Visit the BlackBerry Technical Solution Center at www.blackberry.com/btsc.