BlackBerry Desktop software encounters error "BlackBerry Desktop Software could not connect to the update server" when attempting to update the device software

Article ID: KB27584

Type: Support Content

Last Modified: 06-11-2012

 

Product(s) Affected:

  • Desktop Software (Mac OS)
CollapseEnvironment
  • BlackBerry® Desktop Software for Mac

CollapseOverview
When the BlackBerry® Desktop Software is used on a Mac computer to update the device software either for Applications or the core OS, the following error message appears

BlackBerry Desktop Software could not connect to the update server


CollapseCause
This is due to an IT Policy on the BlackBerry smartphone that is blocking access to the WebSL server.
CollapseWorkaround

Backup the BlackBerry smartphone and then remove the IT Policy by performing a reset to factory outlined in KB14202 . Once that is done please proceed to perform the software update; after the software update is complete, please restore the device backup and then the enterprise activation will start.

Disclaimer

By downloading, accessing or otherwise using the Knowledge Base documents you agree:

   (a) that the terms of use for the documents found at www.blackberry.com/legal/knowledgebase apply to your use or reference to these documents; and

   (b) not to copy, distribute, disclose or reproduce, in full or in part any of the documents without the express written consent of RIM.


Visit the BlackBerry Technical Solution Center at www.blackberry.com/btsc.